A simple name change that allows operations/attributes to be used across services that require the same semantic elements works for me.
PARC, A Xerox Company
800 Phillips Rd, 128-27E
Webster NY, 14580-9701
Email: Peter.Zehler at Xerox.com
Office: +1 (585) 265-8755
Mobile: +1 (585) 329-9508
FAX: +1 (585) 265-7441
From: ipp-bounces at pwg.org [mailto:ipp-bounces at pwg.org] On Behalf Of Michael Sweet
Sent: Monday, October 27, 2014 12:05 AM
To: <ipp at pwg.org>
Subject: Re: [IPP] IPP Scan: Updated Get-Next-xxx naming, updated xxx-wait-mode attribute name?
Sorry, follow up since I noticed there is also the next-image-get-interval.
The amended proposal is as follows (with a slight naming change for #2 for consistency):
1. The Get-Next-Document-Images operation will be renamed to Get-Next-Document-Data.
2. The "get-next-images-wait-mode (boolean)" operation attribute will be renamed to "wait-for-document-data (boolean)".
3. The "next-image-get-interval (integer)" operation attribute will be renamed to "document-data-get-interval (integer)".
> On Oct 26, 2014, at 11:53 PM, Michael Sweet <msweet at apple.com> wrote:
>> One of the comments during the Formal Vote for IPP Scan Service concerned multiple document handling in the scan service and some confusion concerning the naming of the Get-Next-Document-Images operation.
>> We would like to change the name of the operation (same operation code) to Get-Next-Document-Data for the final publication of the specification.
>> In addition, while making this change I noticed that the operation accepts a boolean operation attribute called get-next-images-wait-mode, however given that the operation no longer has "images" in the name, the value is true/false (true to wait, false to not wait), and the inspiration from the ippget operation Get-Notifications is called "notify-wait", I would like to change the name of this attribute to "wait-for-data".
>> In summary:
>> 1. The Get-Next-Document-Images operation will be renamed to Get-Next-Document-Data.
>> 2. The "get-next-images-wait-mode (boolean)" operation attribute will be renamed to "wait-for-data (boolean)".
>> Please let me know if you object to either of these changes. We will review these and all other changes for the final draft of the IPP Scan Service specification at the November F2F meeting.
> Michael Sweet, Senior Printing System Engineer, PWG Chair
Michael Sweet, Senior Printing System Engineer, PWG Chair
ipp mailing list
ipp at pwg.orghttps://www.pwg.org/mailman/listinfo/ipp