[IPP] [PWG5100.6] Issue #30: "overrides-supported": 'document-numbers' should be conditionally required depending on "multiple-document-jobs-supported" = 'true'

[IPP] [PWG5100.6] Issue #30: "overrides-supported": 'document-numbers' should be conditionally required depending on "multiple-document-jobs-supported" = 'true'

[IPP] [PWG5100.6] Issue #30: "overrides-supported": 'document-numbers' should be conditionally required depending on "multiple-document-jobs-supported" = 'true'

smith.kennedy at hp.com smith.kennedy at hp.com
Wed May 4 20:26:45 UTC 2016


[Issue Unconfirmed]

PWG 5100.6-2004 section 4.1.7 says:

   This attribute MUST contain the keywords “pages” and
“document-numbers” because
   a Printer MUST support these attributes.

But the 'document-numbers' attribute should not be required
unconditionally; it should be conditionally required depending on whether
the Printer reports "multiple-document-jobs-supported" = 'true'.  If it
doesn't support "multiple-document-jobs-supported" or reports
"multiple-document-jobs-supported" = 'false' then 'document-numbers' should
not be required.

Link: http://www.pwg.org/issues/30



More information about the ipp mailing list