[IPP] ippsample - ipptool Linux dependencies to support IPPS?

[IPP] ippsample - ipptool Linux dependencies to support IPPS?

[IPP] ippsample - ipptool Linux dependencies to support IPPS?

Michael Sweet msweet at apple.com
Fri Oct 13 00:12:40 UTC 2017


Smith,

You need a few things; the following should cover it (and I should just make an INSTALL.md file for this):

    sudo apt-get install autoconf build-essential avahi-daemon avahi-utils libavahi-client-dev libgnutls28-dev libjpeg-dev libnss-mdns libpng-dev zlib1g-dev

For TLS the important one is "libgnutls28-dev".



> On Oct 12, 2017, at 4:28 PM, Kennedy, Smith (Wireless Architect) <smith.kennedy at hp.com> wrote:
> 
> Hi there,
> 
> Trying to get "ipptool" latest from the PWG's ippsample Github project to work using IPPS on Ubuntu 16.04, but it fails because the libraries aren't available. What libraries need to be present for TLS support to be built into ipptool?
> 
> Smith
> 
> /**
>    Smith Kennedy
>    Wireless Architect - Client Software - IPG-PPS
>    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB IF
>    Chair, IEEE ISTO Printer Working Group
>    HP Inc.
> */
> 
> 
> 
> _______________________________________________
> ipp mailing list
> ipp at pwg.org
> https://www.pwg.org/mailman/listinfo/ipp

_________________________________________________________
Michael Sweet, Senior Printing System Engineer



More information about the ipp mailing list