[copied WIMS list to make others aware of these issues]
A Cover is NOT an Interlock (in the Printer MIB) - the Interlock is just the
sensor and logic.
Conflating Cover with Interlock will screw up the semantics of some widely
implemented existing values of 'PrtAlertCodeTC' as well.
In the WIMS and Semantic Model/v2.0 schema Subunits.xsd, the classes
are simply Cover(s).
I dislike abandoning Printer MIB terms - how about 'PrintDeviceCover(s)'?
Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221 Grand Marais, MI 49839
email: imcdonald at sharplabs.com
From: Richard_Landau at Dell.com [mailto:Richard_Landau at Dell.com]
Sent: Friday, October 20, 2006 12:39 PM
To: McDonald, Ira
Subject: What name for Covers?
I think that PrintCovers is a crummy name for a class. Almost everyone who
did not grow up with PrinterMIB would misunderstand the class until they
read the description. I suggest PrintInterlocks. In the Projector &
Display Management group, we are calling the comparable stuff the Interlock
Group. (If there isn't a sensor on the door, then we don't care about it.)
Seem reasonable to use PrintInterlock as a classname instead?
Richard_Landau(at)dell(dot)com, Stds & System Mgt Arch, CTO Office
+1-512-728-9023, One Dell Way, RR5-3, MS RR5-09, Round Rock, TX 78682
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.408 / Virus Database: 268.13.9/490 - Release Date: 10/20/2006
-------------- next part --------------
An HTML attachment was scrubbed...