Discussion seems to have dried up here, without visible concensus on
'ppmPortDescription' (free text) and 'ppmPortPrtChannelIndex' (the
only possible way to correctly correlate 'ports' in PPM MIB with
'channels' in Printer MIB).
Shall I write up these two new objects from the Tokyo review?
I'm strongly opposed to Ron's suggestion of changing the name of
'ppmPortName' to (as proposed) 'ppmPortDescrName' and changing
the _semantics_ from a name (an invariant, installation-time label)
to a free-text description.
We had a firm agreement last December to freeze the _names_ and
_semantics_ of all existing Port Mon MIB objects in February, as
a courtesy to the Microsoft Longhorn team and to print vendor
implementors. Renaming and bending 'ppmPortName' breaks that
agreement, and reduces interoperability (because implementation
of that object would become highly vendor-specific).
Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221 Grand Marais, MI 49839
This archive was generated by hypermail 2b29 : Thu May 05 2005 - 19:06:51 EDT