JMP> Re: IPP> MOD JobState suggestion

JMP> Re: IPP> MOD JobState suggestion

JMP> Re: IPP> MOD JobState suggestion

Tom Hastings hastings at
Wed Jun 4 08:53:35 EDT 1997

At 15:07 06/02/97 PDT, Harry Lewis wrote:


>I understand PENDING, PROCESSING and COMPLETED states. I thought I was
>following a thread, somewhere, that PENDING-STOPPED was another way to say HELD
>and PROCESSING-STOPPED was another way to say NEEDS ATTENTION. Is this what is
>going on... just some renaming? Or do the "dashes" in these names indicate
>separation between a state and a reason?
>I agree with Bob's recommendations, above, to stick with Completed rather than
>Done. Why change? And, for that matter, why not keep HELD and NEEDS ATTENTION?
>What are we gaining. I find these discussions frequently go down the "generic
>language" path until the labels we choose are so vague that, rather than risk
>misinterpretation, the names end up meaning very little at all.
>Harry Lewis

I agree with Harry that we should reconsider the name change
from 'held' to 'pending-stopped' and go back to 'held'.

In looking at the complete spec for job-state and job-state-reasons in IPP
and the corresponding jmJobState and jmJobStateReason1 objects in JMP,
I discovered a problem with our renaming of 'held' to 'pending-stopped':

I've added the following joint IPP/JMP issue to the joint spec:

JOINT IPP/JMP ISSUE - Should we go back to the name 'held', instead of

The IPP protocol has a "job-hold-until", so having the name of the state be
'held' aligns with that name better making it clearer to the user the
relationship between the attribute and the state.  Also some current systems
have a 'held' state, so that current practice for system that have such as
state is to call that state 'held'.  Also the ISO DPA has a 'held' state.
Finally, our sub-classing in the names doesn't work for 'completed', since
we have 'aborted' and 'canceled', not 'completed-aborted' and
'completed-canceled', so why have it for pending-stopped, which may prove
fairly startling to a user, while 'held' is readily understandable.

I think that 'processing-stopped' is fine and is clear that it is a 
sub-state of processing, so I'm not suggesting that we re-open the
'processing-stopped' name change.



More information about the Ipp mailing list