IPP> MOD - 36) ISSUE: Don't require 1.0 support and add REQUIRED "ver sion-numbers-supported" attribute

IPP> MOD - 36) ISSUE: Don't require 1.0 support and add REQUIRED "ver sion-numbers-supported" attribute

IPP> MOD - 36) ISSUE: Don't require 1.0 support and add REQUIRED "ver sion-numbers-supported" attribute

Stefan Andersson stefan.andersson at axis.com
Wed May 5 08:35:37 EDT 1999


On Wed, 5 May 1999, Hastings, Tom N wrote:

> At last week's telecon with a good number of people participating, we
> relaxed the requirement that an IPP/1.1 Client and Printer MUST support
> IPP/1.0 requests and responses and made it a SHOULD.  As a consequence, we
> agreed also agreed that we have to add a REQUIRED
> "version-numbers-supported" so that a client can determine which versions
> are supported.  This attribute will also be added to the RECOMMEND list in
> the directory appendix list.
> 36) ISSUE:  Don't require 1.0 support and add REQUIRED
> "version-numbers-supported" attribute
> RECOMMEND, rather than REQUIRE, conforming IPP/1.1 clients and the IPP/1.1
> Printers to support IPP/1.0 requests and responses.  Therefore, add an
> "ipp-versions-supported" Printer Description attribute.  Also add this
> attribute as RECOMMENDED in the directory schema list in the Appendix.
> 
I can't see that it is possible to do a IPP1.1 that don't support IPP1.0,
the reason for this is the following (from 3.1.7 Versions IPP/1.0: Model
and Semantics):

> Changes to the major version number indicate structural or syntactic
> changes that make it impossible for older version of IPP clients and
> Printer objects to correctly parse and process the new or changed
> attributes, operations and responses.  
>  ...
> Changes to the minor version number indicate the addition of new
> features, attributes and attribute values that may not be understood by
> all IPP objects, but which can be ignored if not understood.  

The last paragraph states that only features that can be ignored may be
added when the minor number is increased, I can't see that this can lead
to a 1.1 compilant server/client that don't support a 1.0 compliant
server/client. If this should be the case the major version number must be
increased,

  /Stefan 
    
--
Stefan Andersson                         Software Engineer
Document Division                        Stefan.Andersson at axis.com
AXIS Communications AB                   Phone: +46 46 270 19 85
Scheelevägen 16                          Fax: +46 46 13 61 30
S-223 70  LUND, SWEDEN                   http://www.axis.com  









More information about the Ipp mailing list