attachment-0001
<html>
We've done a great job of making elements and attributes consistent. As I
write my UPDF parser, I've found it very easy to generalize all the print
media handling selections except for copies and zooming. These two are
just different so we might as well just deal with them differently and in
the clearest way we can.<br>
<br>
I think we should add the elements MinimumValue, MaximumValue,
IncrementValue, and CommandSequence_ID to MediaCopiesList and
MediaZoomingByPercentageList. We can then delete the elements MediaCopy
and MediaPercentage. Finally, MediaCopiesList should be renamed
MediaCopies and MediaZoomingByPercentageList should be renamed
MediaZoomingByPercentage.<br>
<br>
I agree that we should change all enums so that they use the same
predefined value ("proprietary-value") to indicate that a
proprietary value is provided. This is another good step towards
constistency.<br>
<br>
I think defaults should be done by unique ID except for copies and
zooming. A unique ID just doesn't make sense so lets just specify the
integer value.<br>
<br>
<font size=2>Finally, I propose that we create unique names for all
values we want to use with defaults and interdependencies instead of
using the dot syntax we previously discussed. It accomplishes the same
thing but in a much more readable format. For instance lets just say that
COPIES is used to specify the default value for copies in addition to
being the name used in interdependencies when checking or setting values.
This list makes it clear to both the UPDF creator and the UPDF driver
what can be controlled.<br>
<br>
Since I've started talking about interdependencies, I'd also like to
propose that our conditions be limited to "equal" and "not
equal". I believe that all conditions can still be covered this way
and it will make processing the interdependencies much easier.<br>
<br>
Jim<br>
</font></html>