Per our discussion at the WIMS teleconference today, the
following changes should be made to the Counter Spec:
(1) Rename 'TotalWork' counter class to 'WorkTotals',
consistent with the 'SystemTotals' naming
(so that the prefix 'Total' is _only_ used as a
qualifier for a single, individual counter like
'TotalAlerts' in the 'Monitoring' counter class
and the suffix 'Totals' plural is used _only_ to
modify the name of a counter class).
(2) Delete 'Input/OuputKOctets' and 'Input/OutputMessages'
from the 'Monitoring' counter class.
(3) Preserve 'Input/OutputKOctets' work counters and
add 'Input/OutputMessages' work counters (email, etc.)
to the 'WorkTotals', 'Datastream', and 'Maintenance'
counter classes (for accurate customer billing for
services 'EmailIn/Out', 'FaxIn/Out', 'NetFaxIn/Out')
(4) Make sure that all the terms that the Counter MIB
imports from the Counter Spec are indeed defined.
(5) Rename section 2.2 from 'Other Terminology' to
'Imaging Terminology' (consistent with the Counter
MIB and the actual terms defined there).
(6) Replace entirely the erroneous definition of the term
'Messages' in section 2.2 with the singular noun
Message: A single application protocol request or response
(that may consist of multiple application protocol data units)
received or sent by Service such as EmailIn or FaxOut.
(7) Reorganize Figure 4:
- change title to 'Figure 4 Counter Classes'
(elements as currently used is ambiguous)
- change first sentence below from 'The elements...'
to 'The counter classes...' for clarity
- delete entirely the erroneous Counters bubble
- line up across the top the MediaUsed, WorkTotals,
Availability, and Monitoring bubbles (as peers)
- put single-ended arrows showing counter rollup
that terminate at the WorkTotals top bubble
from each of the bottom Datastream, Auxiliary,
Maintenance, Waste, and (dotted) Unknown bubbles
Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221 Grand Marais, MI 49839
email: imcdonald at sharplabs.com