attachment

<div dir="ltr"><div>Hi Mike and Smith,</div><div><br></div><div>I much prefer Mike's second alternative, i.e., "-acquisition" alone for "in-progress",</div><div>because it's a state-reason and doesn't need "in-progress" or "processing" suffix.</div><div><br></div><div>I suggest that "paused" (the "finished" pause transition) versus "resuming" (the </div><div>"in-progress", that is expressed as a gerund) were past attempts at readability.</div><div><br></div><div>Cheers,</div><div>- Ira</div><div><br></div><div><div dir="ltr" class="gmail_signature" data-smartmail="gmail_signature"><div dir="ltr"><div><div dir="ltr"><div><div dir="ltr"><div><div dir="ltr"><div><div dir="ltr"><div><div dir="ltr"><div><div dir="ltr"><div><div dir="ltr"><div><div dir="ltr"><i><font size="1">Ira McDonald (Musician / Software Architect)</font></i></div><div><i><font size="1"></font></i></div><div dir="ltr"><i><font size="1">Co-Chair - TCG Mobile Platform WG</font></i></div><div><i><font size="1"></font></i></div><div dir="ltr"><i><font size="1">Chair - Linux Foundation Open Printing WG<br>Secretary - ISTO Printer Working Group<br>Co-Chair - ISTO PWG Internet Printing Protocol WG<br>IETF Designated Expert - IPP & Printer MIB<br>Blue Roof Music / High North Inc<br><a style="color:rgb(51,51,255)" href="http://sites.google.com/site/blueroofmusic" target="_blank">http://sites.google.com/site/blueroofmusic</a><br><a style="color:rgb(102,0,204)" href="http://sites.google.com/site/highnorthinc" target="_blank">http://sites.google.com/site/highnorthinc</a><br>mailto: <a href="mailto:blueroofmusic@gmail.com" target="_blank">blueroofmusic@gmail.com</a><br>(permanent) PO Box 221  Grand Marais, MI 49839  906-494-2434</font></i></div></div></div></div></div></div></div></div></div></div></div></div></div></div></div></div></div></div></div><br></div><br><div class="gmail_quote gmail_quote_container"><div dir="ltr" class="gmail_attr">On Wed, Oct 21, 2026 at 9:01 AM Michael Sweet via ipp <<a href="mailto:ipp@pwg.org">ipp@pwg.org</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">Smith,<br>
<br>
Sorry, I had an action to update the wiki page...<br>
<br>
I had originally proposed renaming 'xxx-in-progress' to 'xxxing' to better match existing progress/transitional keywords and removing 'xxx-failed' to further reduce the number of keywords we are adding, not being sure that they provide useful/available/actionable information.  Discussions in our last concall had consensus on keeping the 'xxx-failed' keywords along with the recommendation to use "printer-state-message" and "printer-detailed-status-messages" attributes.<br>
<br>
Some existing keyword examples:<br>
<br>
- 'moving-to-paused' and 'paused' and 'resuming'<br>
- 'stopping' and 'stopped-partly'<br>
- 'subunit-cooling-down' and 'subunit-over-temperature'<br>
- 'subunit-warming-up' and 'subunit-under-temperature'<br>
<br>
Alternatives could be:<br>
<br>
- 'firmware-update-acquisition-failed'<br>
- 'firmware-update-acquisition-processing'<br>
- 'firmware-update-validation-failed'<br>
- 'firmware-update-validation-processing'<br>
- 'firmware-update-installation-failed'<br>
- 'firmware-update-installation-processing'<br>
- 'firmware-update-activation-failed'<br>
- 'firmware-update-activation-processing'<br>
<br>
or:<br>
<br>
- 'firmware-update-acquisition'<br>
- 'firmware-update-acquisition-failed'<br>
- 'firmware-update-validation'<br>
- 'firmware-update-validation-failed'<br>
- 'firmware-update-installation'<br>
- 'firmware-update-installation-failed'<br>
- 'firmware-update-activation'<br>
- 'firmware-update-activation-failed'<br>
<br>
<br>
> On Oct 20, 2026, at 5:26 PM, Smith Kennedy <<a href="mailto:smitty.standards@gmail.com" target="_blank">smitty.standards@gmail.com</a>> wrote:<br>
> <br>
> Hi Mike and all,<br>
> <br>
> I'm starting to dig into creating the next draft of IPP Firmware Update Extensions v1.0 so that I can have a draft completed for review at the F2F and also hopefully have my prototype updated as well. I was reviewing what we have in the wiki:<br>
> <br>
> <a href="https://github.com/istopwg/ippsample/wiki/Firmware-Updates#second-revision" rel="noreferrer" target="_blank">https://github.com/istopwg/ippsample/wiki/Firmware-Updates#second-revision</a><br>
> <br>
> The one thing that bothers me a little is the keyword structures. What has currently been proposed:<br>
> <br>
> 'firmware-update-acquiring'<br>
> 'firmware-update-acquisition-failed'<br>
> 'firmware-update-validating'<br>
> 'firmware-update-validation-failed'<br>
> 'firmware-update-installing'<br>
> 'firmware-update-installation-failed'<br>
> 'firmware-update-activating'<br>
> 'firmware-update-activation-failed'<br>
> <br>
> We changed from 'firmware-update-<PHASE>-in-progress' to 'firmware-update-<PHASE>ing'. This model seems a bit awkward because the "<PHASE>" substring of "<PHASE>ing" differs from the "<PHASE>" substring in "<PHASE>-failed". At the end of the day I don't actually care that much which one we choose but I want to try to avoid another round of string modifications. So should we have the above? Or should we have this?<br>
> <br>
> 'firmware-update-acquisition-failed'<br>
> 'firmware-update-acquisition-in-progress'<br>
> 'firmware-update-validation-failed'<br>
> 'firmware-update-validation-in-progress'<br>
> 'firmware-update-installation-failed'<br>
> 'firmware-update-installation-in-progress'<br>
> 'firmware-update-activation-failed'<br>
> 'firmware-update-activation-in-progress'<br>
> <br>
> WDYT?<br>
> <br>
> Smith<br>
> <br>
> <br>
> <br>
>> On Oct 8, 2026, at 2:29 PM, Michael Sweet via ipp <<a href="mailto:ipp@pwg.org" target="_blank">ipp@pwg.org</a>> wrote:<br>
>> <br>
>> All,<br>
>> <br>
>> I have posted the minutes from today's IPP workgroup conference call to:<br>
>> <br>
>>    <a href="https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-concall-minutes-20261008.pdf" rel="noreferrer" target="_blank">https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-concall-minutes-20261008.pdf</a><br>
>> <br>
>> Our next conference call is on October 24, 2026 at 3pm ET.<br>
>> <br>
>> ________________________<br>
>> Michael Sweet<br>
>> <br>
>> _______________________________________________<br>
>> ipp mailing list<br>
>> <a href="mailto:ipp@pwg.org" target="_blank">ipp@pwg.org</a><br>
>> <a href="https://www.pwg.org/mailman/listinfo/ipp" rel="noreferrer" target="_blank">https://www.pwg.org/mailman/listinfo/ipp</a><br>
> <br>
<br>
________________________<br>
Michael Sweet<br>
<br>
_______________________________________________<br>
ipp mailing list<br>
<a href="mailto:ipp@pwg.org" target="_blank">ipp@pwg.org</a><br>
<a href="https://www.pwg.org/mailman/listinfo/ipp" rel="noreferrer" target="_blank">https://www.pwg.org/mailman/listinfo/ipp</a><br>
</blockquote></div>