PMP Mail Archive: Re: PMP> Another hrBit

PMP Mail Archive: Re: PMP> Another hrBit

Re: PMP> Another hrBit

Jay Martin (jkm@underscore.com)
Thu, 11 Dec 1997 11:49:38 -0500

I'd agree with this proposal, so long as the name is changed to
better reflect the semantics. Maybe something like:

pmOverduePreventiveMaintenance

I know it's a bit long, but it clearly states the semantics and
scope of the variable.

...jay

----------------------------------------------------------------------
-- JK Martin | Email: jkm@underscore.com --
-- Underscore, Inc. | Voice: (603) 889-7000 --
-- 41C Sagamore Park Road | Fax: (603) 889-2699 --
-- Hudson, NH 03051-4915 | Web: http://www.underscore.com --
----------------------------------------------------------------------

Harry Lewis wrote:
>
> I'd like to extend the proposal for new hrPrinterDetectedErrorState bits by
> adding one more bit
>
> > pmOverdue 6 warning(3) or down(5)
>
> This bit would be set if and when the device detected that a preventive
> maintenance
> schedule had been exceeded. It would be up to the implementation if this
> stops printing or not (typically, not!).
>
> Harry Lewis - IBM Printing Systems