Excellent observation. (I'll bet there are only ~50 more of those
kinds of interop issues waiting in the wings, no?)
I sure hope that agent implementors implemented the prtInputName
as R/W. Presetting the value to reflect the corresponding value
of prtInputDescription seems like a pretty reasonable thing to do,
If most folks this prtInputName should be deprecated, I really don't
have a problem with that. However...be careful, as you might start
a "deprecation landslide" in doing so. There are probably *many*
other MIB objects that should also be deprecated if prtInputName
Hey, I hope IBM keeps banging on this interop stuff! You sure are
fleshing out some interesting stuff.
----- Begin Included Message -----
Date: Fri, 7 Mar 97 12:35:53 MST
From: "Harry Lewis <email@example.com>" <harryl@vnet.IBM.COM>
Subject: PMP> Input Name vs Description
In reviewing the interop results, it appears that more vendors favored
support of the localized prtInputDescription over prtInputName and
vendors that did support both seem to put the same information in both.
Note that prtInputName is r/w and prtInputDescription is r/o and we don't
have a feel for who implemented prtInputName as r/w.
Most of the information in these objects is stuff like Tray-1, Tray-1,
Manual, Envelope Tray... etc.
I guess I thought, since prtInputName is r/w, that it's purpose was a bit
different. I thought it would be useful to apply names like Tray-1, since
this is a common reference, but then also to allow management applications
to set names like (Invoice Tray, Boss's Tray, Tickets... or whatever).
Since it looks like most everyone treated these two objects the same,
should be clarify and or deprecate one of the objects?
I think it would be helpful to the "implementation experience" to hear what
others thought about these objects as they pertain to implementations.
----- End Included Message -----